Jump to content

BIRT Developer Center
Download


Photo
- - - - -

How to disable interactivity for specific columns


  • Please log in to reply
3 replies to this topic

#1 Ilalaina

Ilalaina

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 02 February 2012 - 10:05 PM

Hi all,

I'm using Birt Designer Pro 11, and I'm designing a report which will be available on IPortal, displaying a textboxes on a column for saving user input.

My question is how to disable interactivity (by Jsapi if possible) on a specific colum, cause I'm using JQuery datepicker on these textboxes, and it's not working until I disable interactivity.

Thanks for your help.

Ilalaina.

#2 averma

averma

    Senior Member

  • Members
  • 713 posts

Posted 06 February 2012 - 12:21 PM

Hi IIalaina,
TextItem control does not offer any interactivity so it should not impact your javascripts events. I would recommend you to debug this further to see whats causing the conflict.
Ashwini

Ashwini

Follow me on Twitter
Read my Blog BIRT Rocks!


#3 Ilalaina

Ilalaina

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 29 February 2012 - 03:53 AM

Hi Averma, thanks for the reply.

It's because when I click on the cell the interactivity with the column is enabled. Do you see what I mean, the column is highlighted in gray and the options in the header appears ( filtering, sorting ...)
The first time I click the datepicker is fired, everything is OK, but the interactivity is also enabled, so the column is like overlayed, until I click anywhere else on the table.

#4 averma

averma

    Senior Member

  • Members
  • 713 posts

Posted 29 February 2012 - 11:51 AM

Unfortunately it is not possible to enable/disable interactivity selectively on report elements, but you can call a script to disable IV when the mouse is clicked inside the text box. To disable IV get a handle to actuate viewer and call the following script:

viewer.disableIV();
viewer.submit();

Ashwini

Follow me on Twitter
Read my Blog BIRT Rocks!