Jump to content

BIRT Developer Center Download


Photo
- - - - -

Problem with drillthrough hyperlinks using crosstabs in Maximo 7.5


  • Please log in to reply
No replies to this topic

#1 Kyuuri

Kyuuri

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 09 May 2016 - 11:57 PM

I'm using Birt 3.7.1. against Maximo 7.5 and has run into an issue concerning adding drillthrough hyperlinks on data elements in crosstabs.

 

The hyperlinks work fine in the Eclipse html viewer but after importing the report to maximo klicking a hyperlink generates the following error:

 

"Error 500: Error occured in server, check serverlog for detail"

 

After some digging I managed to find the server log and it hints that the issue is caused by a null pointer exception in ReportRequestProcessServlet (see attached serverlog.txt).

 

By method of comparisson of hyperlinks between regular working drillthroughs and ones generated by a cross-tab element (I tried this on 2 different crosstab reports). It looks to me like the report request token is not included in the generated hyperlink causing an invalid report request. Which pretty much has me stuck.

 

Has anyone else encountered this issue? Is there a known workaround or ideas for a workaround?

I'm thinking of manually generating the drillthrough hyperlink by using a dynamic text hyperlink. I've done some light test by copy pasting working hyperlinks into browser and the approach seems to work (as long as the attached request token is till active/valid). The problem is, I don't know how to fetch or generate a valid report token for the current session...

Attached Files