BIRT Developer Center Download

Supported Environments for
BIRT iServer 11SP5


This document describes the supported environments and policies for Actuate products used as part of an BIRT iServer deployment.

BIRT iServer Deployment

Operating Systems

Operating System Versions
Windows 1 7 Professional, 7SP1 Professional,
8.1 Enterprise,
Windows 10
Windows Server 1 Windows Server 2008, 2008 R2,
Windows Server 2012 Standard, 2012 R2,
CentOS 2 6.3, 6.5
OpenSUSE Linux 2, 3 12.2, 12.3, 13.1
Oracle Linux 2, 4 5.5
Red Hat Enterprise Linux AS 2 5.0, 5.3 - 5.10, 6.1 - 6.5, 7.2
SUSE Linux Enterprise Server 2 10, 11SP3, 129
Solaris 5 10
AIX 2, 6, 7, 8 6.1, 7.1, 7.2

Notes:

  1. Service Packs from Microsoft are supported
  2. Minor version updates of Major versions for Linux, Sun or AIX operating systems are supported
  3. On Linux, the libstdc++ library is required and must be installed before installing BIRT iServer. This library is present by default on most systems. Additionally, the Openmotif (32-bit) bundle is required and must be installed before installing the BIRT iServer. BIRT iServer needs libXm.so.3 which is part of Openmotif 2.2 or libXm.so.4 which is part of Openmotif 2.3
  4. Oracle Linux 5.5 is certified only for the iServer encyclopedia database to use the Oracle Database Server version 11G R2
  5. On SUSE Linux Enterprise Server 10, the following patches are required - glibc-locale-2.5-34.7 and glibc-2.5-34.7.
  6. On AIX, IBM XL C/C++ V9.0 for AIX Runtime Environment Component or the IBM VisualAge C++ Professional V9.0 for AIX Runtime Environment component is required.
  7. On AIX 7.1 APAR IV09585 is required to work with JDK 1.7. IBM JRE 8 requires AIX 6.1 to be oslevel 6100-07 or higher and AIX 7.1 to be oslevel 7100-03 or higher.
  8. On AIX, exporting HTML5 charts to another format fails for Java 8. (See release notes). No issues for Java 7.
  9. SLES 12 does not work out of the box for e.Reports. Prerequisites for supporting e.Reports include: libpng14-14-1.4.8-3.1.2.x86_64.rpm, libpng14-14-32bit-1.4.8-3.1.2.x86_64.rpm, openmotif-libs-32bit-2.3.4-26.1.x86_64.rpm and glibc-devel

System Requirements

BIRT iServer Resources Type/Amount
Processors Windows: x86 compatible, Pentium 1 GHz or higher
Linux: x86 compatible, Pentium 1 GHz or higher
Solaris: All hardware supported by OS version (Except x86 compatible)
AIX: Power
RAM 8GB
Free disk space 1.5 GB Minimum
Information Console and Management Console Proxy Resources Type/Amount
Processors Same as BIRT iServer
RAM 1GB minimum
Free disk space 300 MB minimum

Notes:

  • Machine configurations are minimum recommended guidelines. Actual hardware configurations required will vary depending on users, load, and data and other factors.
  • BIRT iServer products are 32-bit applications but can work natively in a 64-bit environment.

Database Software for BIRT iServer Encyclopedia

Starting with Actuate 11, customers can use their existing database servers to store the BIRT iServer encyclopedia.

Database Servers Server Versions
Oracle 11g R1 & R2, 12cR1
PostgreSQL Database 8.4, 9.0, 9.2, 9.2.15 (provided with Actuate products)
Microsoft SQL Server 2008, 2008 R2, 2012, 2014
IBM DB2 9.7, 10.1, 10.5


Web Browsers and Adobe Reader

Browser Versions
Google Chrome (Windows and Linux)1 55
Internet Explorer (Windows only) 10 and 11
Microsoft Edge2 38 on Windows 10
Mozilla Firefox (Windows and Linux) 51
Safari (Mac OS X only) 9.1.2 (For iPortal only)
Adobe Reader 8.0, 9.0, 10.0 and 11.0

Launching the Actuate Analytics and e.Analysis viewer plugin is not supported in Chrome or Edge Browsers

  1. Chrome has dropped support for NPAPI.
  2. Edge no longer supports any java applets.


Application Servers for Information Console, Management Console Proxy and Actuate BIRT Java Components war and ear deployments

Application Servers Server Versions
Apache Tomcat 6.0 - (Java 7 only)
7.0, 7.0.47, 7.0.69 (Included with Actuate Products) -
(Java 7 or Java 8)
8.5.11 - (Java 7 or Java 8)
IBM WebSphere App. Server 7, 8.5 - (Java 7 only)
8.5.5.9 - (Java 7 or Java 8)
9.0.0.0 - (Java 7 or Java 8)
JBoss Application Server 6.3.0 - (Java 7 only)
7.0.0 - (Java 7 or Java 8)
WildFly (JBoss Application Server) 10.1.0 - (Java 8 only)
Jetty HTTP & Application Server 7.3.x, 7.4.x, 7.6.x, 8.x, 9.2 - (Java 7 only)
9.4.1 - (Java 7 or Java 8)
Oracle WebLogic App. Server 10gR3(10.3) - (Java 7 only)
11g R1(10.3.6) - (Java 7 only)
12c R3 (12.1.3) - (Java 7 or Java 8)

Notes:

  • Applications servers listed should work in any operating system as long as the application server vendor states that it supports the operating system in question.
  • Information Console can only be used with BIRT iServer release of the same version. Different versions of BIRT iServer and the Information Console cannot be used together.

Java SE Runtime Environment (JRE)

JRE Version Supported OS
Oracle JRE 6.0 Windows, Solaris, Linux
Oracle JRE 7.0_51 (Included with BIRT iServer) Solaris
Oracle JRE 8.0_401
Oracle JRE 8.0_112 (Included with BIRT iServer)
Windows, Linux
IBM JRE 6.0 AIX
IBM JRE 7 Release 1 AIX
IBM JRE 8.02,3
IBM JRE 8.0.0.3212,3 (Included with BIRT iServer)
AIX

Notes:

  • Customers must check directly with the JRE and OS vendors and install all the necessary OS patches for their JRE-OS configuration.
  • Actuate 11 releases do not support Sun JRE 5.0 for BIRT iServer.
  1. Oracle JRE 8.0_x cannot be supported for 11SP5 on Solaris systems, as it is not available in a 32 bit version.
  2. IBM JRE 8 requires AIX 6.1 to be oslevel 6100-07 or higher and AIX 7.1 to be oslevel 7100-03 or higher
  3. On AIX, exporting HTML5 charts to other format fails for Java 8 (See release notes).
    No issues for Java 7.

Actuate BIRT iServer APIs and Extensions

Development Environment Platform
Information Delivery API This is a platform independent, XML API based on SOAP 1.1 specification. Communication with the BIRT iServer is through HTTP (version 1.0 and 1.1 are supported).
Java Report Server Security Extension This is a Java based, platform independent interface


WSDL Toolkits for Information Delivery API

WSDL Toolkits Version and Platform
Microsoft Visual Studio .NET 2008 - Windows only (Not Applicable Solaris AIX Linux)
Apache Axis 1.2, 1.4 - Windows, Solaris, AIX, and Linux)


Email Servers

  • All SMTP servers are supported that comply with the following IETF standards: RFC 821 and RFC 822. Virtually all commercially available STMP servers comply with the above standards. Examples of emails servers that support this include Sendmail on UNIX and Microsoft Exchange 2007 on Windows.

X Server

  • Actuate BIRT iServer on UNIX requires an X Server for report rendering and printing. Actuate fully supports and tests X11R5.x and X11R6.x X Server installations using graphics hardware. If the UNIX machine does not have graphics hardware installed, Actuate also supplies and supports an X Server software emulator, Xvfb (X Server virtual frame buffer).

Content Export

Viewer Version and Products
Microsoft Excel Excel 2003, 2007, 2010 (BIRT, BIRT Studio, BIRT Spreadsheet & e.Reports)
Excel 2002, 2003 and 2007 (Actuate Analytics and e.Analysis)
Microsoft Word Word 2003, 2010 (All Products)
Microsoft PowerPoint PowerPoint 2003, 2007, 2010 (All Products)

Notes:

  • There are known issues with opening old Microsoft Office (2003 or older) documents in Microsoft Office 2010. These issues are attributed to stringent default security settings in MS Office 2010. If using Microsoft Office 2010, Actuate recommends exporting to Microsoft Office 2010 formats (e.g. xlsx, pptx, docx etc.) or updating default settings for Microsoft Office 2010 to allow opening of older file formats.
  • Actuate e.Reports supports export to older Microsoft Office formats ( xls, doc, ppt etc.).

Printers

Report Type Printer
BIRT All Platforms : PostScript (Level 3) printers
e.Reports Windows : All Printers
Linux, Solaris, AIX : PostScript (Level 1 or 2) printers

Notes:

  • Actuate uses best efforts to achieve WYSIWYG but this is not guaranteed. Reports may print identically across platforms.
  • On Windows, Actuate supports any Windows supported printer. On Linux, color printing of text, images and graphs is only supported for Postscript printers.

Designers


BIRT Designer Professional and Open Source BIRT Designer

BIRT Designer State Versions
Actuate BIRT Designer Professional Recommended 11.0.5
Open Source BIRT Designer Recommended 3.7.2
Open Source BIRT Designer Compatible 2x, 3x

BIRT Designer Professional

Operating Systems

Operating System Versions
Windows 7 Professional, 7SP1 Professional
8.1 Enterprise
Windows 10
Server 2008 Enterprise, 2008 R2 Enterprise
Server 2012 Standard, 2012 R2 Standard

Notes:

  • Windows Service Packs from Microsoft are supported as long as Microsoft states that the Service Packs are compatible.
  • Both the 32-bit and 64-bit editions of Windows 7 Professional are supported.

System Requirements

Resources Type/Amount
Processors Windows: x86 compatible, Pentium 1 GHz or higher
RAM 512 MB (1GB recommended)
Free disk space 300 MB Minimum

Notes:

  • Machine configurations are minimum recommended guidelines. Actual hardware configurations required will vary depending on users, load, and data and other factors.
  • Actuate products are 32-bit applications but can work natively in a 64-bit environment.

Database Sources

Open Source BIRT Designer JDBC Drivers

Database Servers JDBC Driver Version
JDBC Drivers JDBC 2.0 Type 2, 3, 4 and 5 compliant drivers
Apache Cassandra Open source data connector for Apache Cassandra
Apache Derby Database Apache Derby Network Client JDBC driver
Hadoop Hive JDBC driver for Hadoop data source
Hive Server 2 Hive ODA Connector for Hive Server 2 data sources
Microsoft Excel Connector for Microsoft Excel files
Mongo DB Open source data connector for Mongo DB data sources


Commercial BIRT Designer Professional JDBC Drivers

Database Servers JDBC Driver Version
Amazon DynamoDB ODA Connector for Amazon DynamoDB NOSQL Database service
Apache Derby Apache Derby Network Client JDBC driver
Cloudera CDH Hive JDBC Driver for Cloudera CDH4 data sources
Hadoop Hive JDBC driver for Hadoop data source
IBM DB2 Server DataDirect Connect for JDBC, IBM DB2 Universal JDBC Driver
IBM Informix Server DataDirect Connect for JDBC, IBM Informix JDBC driver
Microsoft SQL Server DataDirect Connect for JDBC
MySQL Enterprise MySQL Connector/J JDBC Driver 5.0, 5.1
Oracle Database Server DataDirect Connect for JDBC, Oracle Thin JDBC driver
PostgreSQL Database PostgreSQL Database
Salesforce.com DataDirect Connect XE for JDBC Salesforce.com
Sybase Adaptive Server DataDirect Connect for JDBC


Non-JDBC Drivers

  • Cassandra Scripted Data Sources
  • Flat Files
  • POJO (Plain Old Java Objects)
  • Web Services
  • XML Data Source

Notes:

  • BIRT is expected to work with any JDBC 2.0 Type 2, 3 and 4 compliant database drivers. Note however that use of JDBC-ODBC bridge drivers is explicitly not recommended or supported

e.Report Designer

Operating Systems

Operating System Versions
Windows 7 Professional, 7SP1 Professional
8.1 Enterprise
Windows 10
Server 2008 Enterprise, 2008 R2 Enterprise
Server 2012 Standard, 2012 R2 Standard

Notes:

  • Windows Service Packs from Microsoft are supported as long as Microsoft states that the Service Packs are compatible.
  • Both the 32-bit and 64-bit editions of Windows Operating Systems are supported.

System Requirements

Resources Type/Amount
Processors Windows: x86 compatible, Pentium 1 GHz or higher
RAM 512 MB (1GB recommended)
Free disk space 350 MB Minimum
Resolution 1024x768, 256 colors

Notes:

  • Machine configurations are minimum recommended guidelines. Actual hardware configurations required will vary depending on users, load, and data and other factors.
  • Actuate products are 32-bit applications but can work natively in a 64-bit environment.

Databases

Database Servers - Accessible via Native Clients
(7.1.2 to 7.1.4 bundled with Actuate for connectivity to mainstream DBMS)

Data Base Server Version
Oracle 11g R1 & R2, 12c R1
IBM DB2 Universal Database (UDB) 9.5, 9.7, 10.1, 10.5
Microsoft SQL Server 2005, 2008 (Original Release)
Sybase Adaptive Server (ASE) 12.5.2, 12.5.3, 15, 16
Informix Dynamic Server 10, 11
PostgreSQL 8.4, 9.x

BIRT Information Designer

The BIRT Information Designer is available within the BIRT Designer Professional and e.Report Designer Professional products.

Bundled drivers

Database Servers Version ODBC Version JDBC Version
Oracle 11g R1, R2 12c R1 DataDirect 7.10.04 DataDirect 5.01.02
IBM DB2 Universal Database 9.5, 9.7, 10.1, 10.5 (requires IBM DB2 Connect 9.7) DataDirect 7.10.04 DataDirect 5.01.02
Microsoft SQL Server 2005, 2008, 2014 (Original release and Windows only) DataDirect 7.10.02 DataDirect JDBC 5.01.02
Sybase 12.5.3, 15, 16 DataDirect 7.10.02 DataDirect JDBC 5.01.01
Informix 10, 11 DataDirect 7.10.02 DataDirect 5.01.01
MySQL 5.1 DataDirect 7.10.04 Connector/J 5.1
PostgreSQL 8.4 DataDirect 7.10.04 JDBC driver version 8.4

Notes:

  • The DataDirect drivers that Actuate supplies can be used only with Actuate products
  • BIRT Information Objects is expected to work with any JDBC 3.0 compliant database driver.
  • Any custom data source can be accessed using open-source Eclipse based DTP compliant plugin

BIRT Spreadsheet Designer

Operating Systems

Operating System Versions
Windows 7 Professional, 7SP1 Professional
8.1 Enterprise
Windows 10
Server 2008 Enterprise, 2008 R2 Enterprise
Server 2012 Standard, 2012 R2 Standard

Notes:

  • Windows Service Packs from Microsoft are supported as long as Microsoft states that the Service Packs are compatible.
  • Both the 32-bit and 64-bit editions of Windows 7 Professional are supported.

System Requirements

Resources Type/Amount
Processors Windows: x86 compatible, Pentium 1 GHz or higher
RAM 512 MB (1GB recommended)
Free disk space 255 MB Minimum

Notes:

  • Machine configurations are minimum recommended guidelines. Actual hardware configurations required will vary depending on users, load, and data and other factors.
  • Actuate products are 32-bit applications but can work natively in a 64-bit environment.

Databases Sources

Database Server Branded Data Direct JDBC Driver Versions
DB2 5.01.02
Informix 5.01.01
Oracle 5.01.02
SqlServer 5.01.02
Sybase 5.01.01

Notes:

  • JDBC 2.0 Type 2, 3 and 4 compliant database drivers are supported
  • Use of JDBC - ODBC bridge drivers is not supported
  • The BIRT Spreadsheet technology supports a number of non-JDBC data sources. These include Actuate BIRT Report Documents, BIRT Information Objects, POJO (Plain Old Java Objects), Web Services, XML and Flat Files.

BIRT Spreadsheet Engine and API

  • The BIRT Spreadsheet Engine is a JAR that provides API to build XLS and XLSX documents. The JAR requires Java 1.6 or later and can run on any platform that supports java 1.6 – including web app servlets, app servers, and custom command line applications, etc.

Export to Excel

  • The Spreadsheet viewers Microsoft Excel 2002, 2003, 2007 and 2010 are supported by the BIRT Spreadsheet technology.

Actuate Obsolescence Policy


Major Release Family Definitions:

  • Major Release: : Names for Major Release use only whole numbers. This is a full release and there will be significant new functionality including features, supported product updates and maintenance fixes. Customers may need to make minor code changes, recompile reports, or export/import Report Encyclopedia to upgrade to a Major Release
  • Service Pack: : Names for a Service Pack use whole numbers followed by the Service Pack number. This is a full release upgrade with additional new features, supported product updates and maintenance fixes. Migration to a Service Pack within the same Major Release will not require code changes.
  • Fix Build: Fix builds are based on the latest Service Pack of a major release to provide relief from product defects. A complete release, product, file/set of files are available as a download from the Actuate Support site, and are available to customers on maintenance.

Lifecycle Guidelines Timetable:

  • Full Support: Major Release Family is shipped with Full Support.
  • Limited Support: When a new Major Release is shipped the prior Major Release moves to Limited Support for 6 Months.
    • All Customer Support Programs are available
    • No new Service Packs will be released
    • Fix builds may be created at Actuate's discretion
    • Shipping may be available on request
  • End of Life: After the 6 months of Limited Support, the release moves to End of Life for 36 months or 18 months after the initial shipment of the next Major Release, if that occurs later.
    • All Customer Support Programs are available
    • No new Service Packs will be released
    • No new Fix builds will be released
    • Shipping may be available on request
  • Extended End of Life: Extended Life Support extends “End of Life” for up to an additional 3 years.
  • Retired: There will be no further Customer Support, Service Packs, Fix Releases or shipping.

Actuate Obsolescence Roadmap for BIRT iServer Enterprise Deployments

  • Current status and forecast for Actuate product family obsolescence based on the product support lifecycle guidelines.
  • The Actuate BIRT iServer product line exists in parallel to the Actuate BIRT iHub product line.
  • All Releases 10.0 and older are "Retired".
Release RTM Date Status Retired Date Notes
11 Service Pack 5 Feb, 2017 Full Support No forecast retirement date  
11 Service Pack 4 October 25, 2012 Full Support No forecast retirement date Recommended Actuate 11 series release is Actuate 11 SP5
11 Service Pack 3 October 31, 2011 End of Life No forecast retirement date Recommended Actuate 11 series release is Actuate 11 SP5.
11 Service Pack 2 August 12, 2011 End of Life No forecast retirement date Recommended Actuate 11 series release is Actuate 11 SP5.
11 Service Pack 1 1 March, 2011 End of Life No forecast retirement date Recommended Actuate 11 series release is Actuate 11 SP5.
11.0 September 29, 2010 End of Life No forecast retirement date Recommended Actuate 11 series release is Actuate 11 SP5.
10 Service Pack 1 2 April 08, 2009 Retired March 29, 2012 Extended End Of Life support is no longer available
10.0 December 10, 2008 Retired March 29, 2012 Extended End Of Life support is no longer available
9 Service Pack 3 December 21, 2007 Retired June 10, 2010 Extended End Of Life support is no longer available

Notes:

  1. 11SP1 includes the BIRT 2.6.2 Designers
  2. 10SP1 includes the BIRT 2.3.2 Designers